Logo

Upgrade Your Old MSIE6 Browser!

In light of the news of the recent Poodle vulnerability, we have decided to disable SSL 3.0 support our websites minimise any risk to our customers.

This decision is in line with the decisions of other companies such as SagePay and Microsoft. Security is critical to your shopping experience. Despite the news coverage, there is little to worry about. In fact, there is just one thing you need to do:

If you are using Internet Explorer 6, you will need to upgrade to a higher version of Internet Explorer, or use Firefox or Chrome. Microsoft have decided not to release an update for this now unsupported browser.

logo

If you see this, you know you are in safe hands!